Roots Discourse

2 issues upon Vagrant Up and Provision - Catalina

I’ve just bought a new Macbook, cloned my existing roots project which was working fine on my old Macbook (High Sierra).

My OS:
macOS Catalina - 10.15

I’ve got the following installed:
Vagrant - 2.2.7
VirtualBox - 6.1.4
Ansible 2.8.0

This is the top two lines from /trellis/CHANGELOG.md in order to show what version of Trellis I have:

Head

  • Update wp_cli_version to 2.4.0 (#1131)

The issues:
I’m unable to get vagrant up running without error. I’ve just tried vagrant reload and this is the error right now:

==> default: Creating bind mounts after synced_folders…

default: /vagrant-nfs-domain.co.uk => /srv/www/domain.co.uk/current

A bindfs command failed to run!

Command (runned via sudo):

/usr/bin/bindfs --force-user=vagrant --force-group=www-data --perms=u=rwX:g=rD:o=rD -o nonempty /vagrant-nfs-domain.co.uk /srv/www/domain.co.uk/current

Standard output:

Error output:

Could not open source directory

Please check options values and compatibility. For a complete

documentation, run sudo bindfs --help on the VM. You can see

it online at http://bindfs.org/docs/bindfs.1.html

This is the issue when I try vagrant provision

TASK [wordpress-install : Install Dependencies with Composer] ******************

System info:

Ansible 2.8.0; Vagrant 2.2.7; Darwin

Trellis Head


Composer could not find a composer.json file in…

My process:
Navigate to /trellis in terminal
Run vagrant reload
After I type in my password I get:

“Terminal” would like to administer your computer etc…

Clicked ok and vagrant continues. Then eventually run in to the error shown above.

Attempts:
I’ve tried: vagrant plugin update - ran fine but no change after trying vagrant up/reload again.
I’ve tried a vagrant destroy and vagrant up twice too.

My hdd is not encrypted either, FileVault is off.

Urgh! Another issue seen after I did another vagrant destroy - vagrant up:

==> default: Cannot create bind mount from '/vagrant-nfs-domain.co.uk' to '/srv/www/domain.co.uk/current': Source path '/vagrant-nfs-domain.co.uk' doesn't exist
==> default: Cannot create bind mount from '/ansible-nfs' to '/home/vagrant/trellis': Source path '/ansible-nfs' doesn't exist
==> default: Cannot create bind mount from '/home/vagrant/trellis/bin' to '/home/vagrant/trellis/bin': Source path '/home/vagrant/trellis/bin' doesn't exist

I’ve seen other mentions of these errors but then solutions based on vagrant releasing patches etc, considering I’ve downloaded everything using latest versions, didn’t expect issues.

I figured out the issue and the solution/issue I think needs adding to the Documentation (if you agree @benword).

Unless I am missing something, you can’t have your repos which contain /trellis etc inside your /Documents directory (/Users/user/Documents/repo).

I moved mine to a new directory: /Users/user/Development and all worked fine!

2 Likes

First I’ve heard of this! Thanks for following up

I was testing a project out in my Downloads folder and getting this same error. It would also fail to vagrant up with an error saying it couldn’t find a composer.json file in /srv/www/myproject.com/current.

Moved the project to my Sites folder, and vagrant up worked the first time.

Strange bug indeed! Glad you figured it out, because it might have taken me a long time to figure that out.

This topic was automatically closed after 42 days. New replies are no longer allowed.