Roots Discourse

$20 for a solution! First Time Deploy to Staging: `Error: This does not seem to be a WordPress install.`

I’m getting the following error when running a deploy to staging for the first time and while I understand what it’s saying I don’t know how to troubleshoot this. Particularly because I’ve basically just followed the Docs instructions on setting up everything so I don’t know why it wouldn’t find the site in the default path.

Related: Johnpbloch/wordpress moved to a new configuration and WP goes missing

Thanks. I have read through that post but it doesn’t seem relevant to me. There’s a lot of talk about things totally unrelated. Maybe it is caused by the same issues but I don’t know what “the answer” is there - especially as it relates to my setup.

I’m brand new to Trellis, I’m just following the instructions, so I’m trying to understand if this is a bug or if I managed to miss a step somewhere…

How does your wordpress_sites.yaml file look for staging? If you SSH to the server and look at /srv/www/<site.com>/current, what’s there?

1 Like

Interestingly, I don’t have a current folder.

For experimentation purposes I:

  1. SSH’d in as web@
  2. Manually created current
  3. Then executed wp core download
  4. Re-rain ansible-playbook deploy.yml -e env=staging -e site=staging.EXAMPLE.com

And got a symlink error. I know how to create symlinks but I’m not sure where to point it to.

/srv/www/staging.kangapestcontrol.com/current exists but is not a symbolic link

But that wouldn’t really solve the root issue obviously. I need to know why this occurred in the first place and whether or not it was user-error or a bug with Trellis.

Thanks for your help everyone.

So I created a symlink and linked it to what one of the two folders inside my releases directory. I re-ran the ansible deploy command and I got past the symlink error. Although, I’m not confident I pointed the symlink to the right spot since there is nothing in the docs that tells me what it should point to exactly. It looks like when I run the ansible deploy that it updates it anyway?

So while I overcame the symlink error I’m back at the original error I mentioned in this thread.

Except now I have a current symlink.

I’d be willing to pay $20 to anyone who can help me solve this issue tonight (meaning get this up and running on staging).

And I attempted to follow the debug instructions of running wp core download inside the web/wp that the symlink is pointing to. Then re-run the command. Still getting the same error.

I’m just unlisting this thread.

That error message is standard from WP-CLI but the solution is never to run wp core download. If WP isn’t found then something else is going on. See the other thread for some guidance.