502 Bad Gateway, PHP won't start

I just updated ubuntu today. Is everyone else up to date or using an older version?

Probably an upstream issue… see https://github.com/oerdnj/deb.sury.org/issues/341

4 Likes

I let the App Store install an update of Command Line Tools for Xcode (OS X 10.11) during the weekend—could that matter?

He doesn’t seem to have a solution yet on this. I am checking the info that he recommends to check now.

After checking: I get the same result that he talks about.

As long as you open Xcode and accept the terms it usually doesn’t cause issues.

1 Like

Just wanted to throw my hat in the ring and say that I’m experiencing the exact same issue. Is there a way to specify a version of PHP to use in order to avoid this kind of thing in the future?

I have tried everything that I can think of and still nothing will work for me. I just copied a trellis install that I know is working and when I re configure the files and run vagrant up again I get the same issue.

I tried setting up the basic example.com site. I did not change anything and ran vagrant up with the same result.

I just went through the same steps as you and can confirm that things are broken, beyond a doubt, right now. The only consolation I have is that it’s apparently not my own fault this time :grin:

1 Like

What version of ubuntu are you using

I grabbed the latest copy of Trellis and Bedrock, so Ubuntu 14.04.4 LTS

I’m at a stand still right now. I have been trying to figure this out all day.

As I mentioned earlier, this is an upstream issue. This will not work at all until it’s resolved by the maintainers of the PHP PPA. At that point you will have to re-provision your server with the updated PPA when it’s fixed.

Similar scenario happened within the past month.

@ben already posted what the problem is: 502 Bad Gateway, PHP won't start

I’m sorry but there’s no real solution right now if you provisioned a server while this has been broken. We’re mostly at the mercy of the PPA provider.

I know you don’t have a timeframe on this. But when this happened before how long did it take before it was fixed.

Getting the 502 Bad Gateway error on development on a fresh install.

The site I setup last week still works fine.

Not trying to imply that anyone on the Roots team is at fault! Apologies if that’s how it came across. Just wanting to provide another data point so that others know they are not alone on this issue.

In a situation like this, what would be the steps in duplicating an existing local Trellis/Bedrock setup?

I have tried to use another Trellis/Bedrock install with no luck. The problem is when you provision the server, which if I’m understanding this correctly is from a 3rd party. So until the PPA Provider fixes the issue you can’t provision the server to get it running. @swalkinshaw said above that unfortunately we are at the mercy of the PPA provider.

This appears to be fixed, but out of interest …

  1. Is this bug preventable?
  2. Could this have affected a deployed site?
  3. I spent a long time trying to figure out a fix for this today only to find out it wasn’t solvable at my end. Is there some obvious error message that I missed that could’ve told me that sooner?
2 Likes
  1. Maybe, but I’m not sure what we can do yet
  2. I think if you re-provisioned a production server during this time it might have broke? Re-deploying wouldn’t break it.
  3. I don’t think so unfortunately. Nothing obvious at least.

Should be noted that if/when we switch to Ubuntu 16.04 this problem kind of goes away because it has PHP7 as the default version. We wouldn’t have to use a 3rd party PPA as far as I know.

2 Likes