ACF-Composer Field Example on server

I have got a working installation of Sage 10/Bedrock/Lando and succesfully created the Field Example with acf-composer.
When I upload the changes to the server (shared host, with a working basic Sage theme) the Field Example doesn’t do anything. There is no field when creating a post. And there is also not a new field visible in Options>Preferences>Panels.
I have acorn 2.05 (for php8) installed as mu-plugin. No errors in the server log. Am I missing something?
These are the theme files on the server:

//folders synced with local machine, after bud clean and bud build
node_modules/      //doesn't belong here I know

composer.json   // added after warning in server log that Acorn couldn't find this file

If anyone else encounters this.
Fields created with log1x/acf-composer or Custom post types created with log1x/poet work for me on a shared host if I rsync the web/app/cache/acorn folder to the server every time I deploy.

Edit: correction, this still doesn’t fully work. Any changes I make to a custom post type locally are not reflected on the production website. I tried publishing everything with Acorn, and running wp acorn view:cache before building and deploying.

Edit 2: Ok I was stupid, I forgot to upload the changed config files as well. So far both ACF composer and Poet seem to work fine for now (fingers crossed).

The initial thing you said is something that I got caught by before, and it was that ACF plugin wasn’t enabled. There aren’t any errors or other indications that the plugins aren’t working correctly but the fields and blocks just don’t appear.