ACF installer setup

Thank you for your help.

Breaking down the responsibilities helps. Anyway, I followed your directions, I was able to create my vagrant local environment but there are no errors.

I vagrant sshed into my system.

In /srv/www/mysite/current/vendor/advanced-custom-fields/advanced-custom-fields-pro:

is

acf.php assets includes lang pro readme.txt

The only plugin in my “plugin” folder is All-In-one migration. Thoughts?

There’s no need to vagrant ssh to your system for any part of plugin management if you have Composer installed locally.

Just change directories to your site directory and type composer update.

Do that and paste the output your get here.

I have one thought, I did receive this error:

The plugin advanced-custom-fields/acf.php has been deactivated due to an error: Plugin file does not exist.

Could the problem be the acf.php file is in the advanced-custom-fields-pro folder and not one step up?

No. Composer will put the plugin into your site/web/app/plugins directory --it doesn’t use the vendor directory.

Is there way to test installer errors?

Can you post the full output of running composer update in the site directory?

Loading composer repositories with package information
Updating dependencies (including require-dev)
Nothing to install or update
Writing lock file
Generating autoload files

I’m actually running out of ideas here. Could you try running rm -rf vendor from site and then run composer update again?

1 Like

… and before composer update running composer clear-cache might help too.

1 Like

Should I push after running composer update?

I’m not sure I understand the question. Push what to where?

EDIT:
Re-reading this I think you mean pushing to production. I recommend resolving this issue locally before trying to make it work in production.

1 Like

Sorry, I meant put to repo.

This worked locally. I forgot to push to repo and it didn’t install on the server. I’m hoping if I go back, push to repo, then reprovision server, it will work. I’m at my dayjob, so I’ll try it tonight, but thank you @MWDelaney and @knowler, I wish I could buy you both a beer, you guys are lifesavers.

1 Like

So I did a clean install,

Did what you said and it worked locally.

I tried to push up to my remote server. Didn’t work,

I tried to follow this, not sure if it worked. I think the issue I’m having is the build-before.yml file.

I’m assuming if I create a build-after file and move it to that, it should work?

Right now I can get Vangrant up to work, I can run:
ansible-playbook server.yml -e env=production

but when I try to:
./bin/deploy.sh production mysite

Nothing is there. (No nginx error).

It turns out there wasn’t any node_modules in my production theme. Do you guys have any idea why that might be? I’m thinking yarn isn’t running.

@knowler
@MWDelaney

Why would your production theme have node_modules? Sage packages up all the JS you need as part of the build process.

I didn’t know that.

Should I be able to run yarn in my production theme? If it try it, it says :

ERROR: There are no scenarios; must have at least one.

AFAIK you should’t be running yarn on your production server. All of your asset processing/compliation happens locally, when you deploy: The deploy process just pushes all your assets from your local machine to the remote one.

@mkSage Please don’t chain separate issues together in the same topic

1 Like