Another Permalink Issue

I can’t seem to get permalinks working on a fresh copy of bedrock with a new db on Ubuntu 13.10. I have confirmed that mod_rewrite is enabled and the .htaccess is present and properly configured. Still no symlinks. :frowning:

Any thoughts on what might be wrong?

Flush permalinks? Go to permalinks and click save

I’ve tried that… several times. So far no dice.

What does sudo a2enmod rewrite output?

“Module rewrite already enabled.”

Try adding the rewrite rules to the vhost config. Or at least check the vhost for Options FollowSymLinks and AllowOverride All inside the appropriate directory location.

Aside from that, I would recommend switching to Nginx. It’s better than Apache and will be the default in Bedrock when Vagrant and Ansible are baked in.

1 Like

It was the AllowOverride rule. Stupid default settings for Apache on Ubuntu. -_-

Thanks for the assist. We are looking at using this as our method for setting up our new wordpress installs. Another question… is there a packagist for roots? (Tell me if I should move this to a new topic.)

For the Roots theme? No. Mostly because we don’t want to encourage its use as a parent theme.

But it’s pretty easy to define that repository yourself in your composer.json.