Ansible falling on composer - openssl (?)

I’m getting an error when running ansible-galaxy install –

downloading role from
[ERROR]: failed to download the file: Failed to validate the SSL certificate
for Make sure your managed systems have a valid CA certificate
installed. You can use validate_certs=False if you do not need to confirm the
servers identity but this is unsafe and not recommended. Paths checked for this
platform: /etc/ssl/certs, /etc/ansible, /usr/local/etc/openssl. The exception
msg was: [SSL: TLSV1_ALERT_PROTOCOL_VERSION] tlsv1 alert protocol version

[WARNING]: - composer was NOT installed successfully.

ERROR! - you can use --ignore-errors to skip failed roles and finish processing the list.

I’ve updated open ssl - here is output:

OpenSSL 1.0.2o 27 Mar 2018
built on: reproducible build, date unspecified
platform: darwin64-x86_64-cc
options: bn(64,64) rc4(ptr,int) des(idx,cisc,16,int) idea(int) blowfish(idx)
OPENSSLDIR: “/usr/local/etc/openssl”

Is this a openssl problem or am I looking in the wrong spot?

Interesting enough, I was on sierra and had another computer on high sierra and it worked perfectly there. So I just updated to high sierra and now everything works. Maybe note that some change in openssl config in high sierra is compliant with the ssl. A little over my head, but just thought i’d share.