Ansible Provision issue

Am facing issue in provisioning the software to my Vagrant box. Even vagrant ssh is not working. Please suggest am stuck for weeks already here. Tried a lot of things but nothing worked out. Am using windows machine with virtual box and setup ubuntu to run my trellis project for development.

PLAY [WordPress Server: Install LEMP Stack with PHP 7.1 and MariaDB MySQL] *****

TASK [Gathering Facts] *********************************************************
System info:
Ansible; Vagrant 1.9.5; Linux
Trellis 0.9.9: December 14th, 2016

Failed to connect to the host via ssh: Connection timed out during banner

fatal: [default]: UNREACHABLE! => {“changed”: false, “unreachable”: true}
to retry, use: --limit @/sites/hostname/websites/trellis/dev.retry

PLAY RECAP *********************************************************************
default : ok=0 changed=0 unreachable=1 failed=0

Ansible failed to complete successfully. Any error output should be
visible above. Please fix these errors and try again.

You could do a vagrant up --debug &> vagrant.log to check for local provisioning issues on VirtualBox with Vagrant. This just to get more details. There is also the option to temporarily change the timeout. See on how to increase in in your Ansible configuration. Never used that option myself though.
If it is for staging or production you can use the -vvv flag for more details on the issue provisioning your server.