Approved comments not showing up

I’m trying to enable JetPack comments on a Roots site (v6.5.1) and the comments won’t show.

I’m using this to call in the JetPack comments:


<?php if ( did_action( 'jetpack_comments_loaded' ) ) : ?> <?php comment_form(); ?> <?php else: ?> <?php get_template_part('templates/comments'); ?> <?php endif; ?>

It accepts a comment, but then the comment doesn’t show. WordPress is set to auto approve them, and the comments show as approved, but they do not show up on the post.

I’ve also tried just using plain old
<?php comment_form(); ?>
but that didn’t change anything.

I talked to JetPack, and they had me enable 2014, and dang it…sure enough the approved comments show in 2014. So I have something wrong in Roots.

Anyone have any ideas as to why comments don’t appear on a Blog post in Roots? I’m using

<?php comment_form(); ?>

Instead of calling in the comments.php file, because when I was doing that, the JetPack comments wouldn’t show up at all.

I’ll pay for support if anyone can help me…

Here’s what’s happening - I place <?php comments_template(); ?> in my single.php file, and the JetPack comment form shows and accepts comments fine. The comments appear in the back end as approved, but will not display on the page.

Can anyone help? This is driving me crazy.

And yes, if I enable the 2014 theme, the comments display fine. It’s something with my Roots theme on both sites.


I’m with Jetpack support and wanted to share here what I wrote in the Jetpack forums to keep Roots items with the Roots community.

Jetpack Comments will replace the comment_form(), but that’s it (e.g. not display comments).

I would check out the comments.php file at
and compare that to

The Roots theme is creating a form itself, instead of relying on WordPress’ built-in process to create the comment form (which Jetpack “plugs” into for the Jetpack Comments form).

Taking out the Roots-made form and adding in comment_form(); should take care of you.

1 Like

Thanks a million Kraft.

They’re working…I was using comment_form() directly in single.php instead of calling the Roots comments.php template file. Once I called the template file back into single.php and replaced the Roots form with the comment_form() everything worked correctly.

Hope that helps someone else.