Roots Discourse

Bedrock composer issue (WordPressCorePlugin.php : No such file)

Hello,

On a fresh Bedrock deployment, I try to run, as indicated on its Github repo (in a clear directory) :

$ composer create-project roots/bedrock

However I keep getting this issue :

…(Above lines snipped for clarity)…
Package operations: 11 installs, 0 updates, 0 removals

  • Installing roots/wordpress-core-installer (1.1.0): Loading from cache
    Plugin installation failed, rolling back
  • Removing roots/wordpress-core-installer (1.1.0)

[ErrorException]
include(/code/project1/bedrock/vendor/roots/wordpress-core-installer/src/WordPressCorePlugin.php): failed to open stream: No such file or directory

create-project [-s|–stability STABILITY] [–prefer-source] [–prefer-dist] [–repository REPOSITORY] [–repository-url REPOSITORY-URL] [–dev] [–no-dev] [–no-custom-installers] [–no-scripts] [–no-progress] [–no-secure-http] [–keep-vcs] [–remove-vcs] [–no-install] [–ignore-platform-reqs] [–] [] [] []

When I go in the “vendor” dir after this error, there is only a bin directory in it (which is itself empty).

I tried to purge composer cache, and also tried on another workstation, issue is the same.
Searched on Discourse and Github Issues for the project, but to no avail.

Thanks for your help about solving this mysterious issue !

Cheers

Issue was solved by running it on a non-Vagrant virtual machine
(was using Laravel Homestead)

This topic was automatically closed after 42 days. New replies are no longer allowed.