Bedrock dev site only works while offline

I’m encountering kind of a strange problem in my setup.

I’ve set up the Bedrock stack inside a standard VVV development vm.
(for various reasons, I’m not using bedrock-ansible).

I also have a couple of other sites in the same dev vm, which I set up using vvv-site-wizard. These sites are fine, no problem.

But when I go to the hostname of the Bedrock site, which is, I just get “this webpage is not available.”
However, when I disconnect from the internet, the wordpress site at loads just fine. I can go into the admin panel and do everything as normal (with the obvious exception that it throws PHP errors because it can’t connect to the web to check for a WP core update at

I’ve checked and re-checked everything in my Bedrock setup to make sure they match the other, working sites. And I’m pretty much at my wit’s end.

The only other thing I can think is that somehow Bedrock’s folder structure is conflicting with VVV somehow.
This could be related to this issue, which sounds similar but slightly different:

Anyone with experience using Bedrock with VVV have any suggestions?

If it works when you disconnect from the internet this leads me to believe it’s just a DNS problem. I have no about your setup or VVV so I’m not sure how you’ve defined that local hostname. When your internet is connected you’re using its DNS servers (maybe your ISPs or whatever it’s configured to use). Seems like there’s some conflict going on which is solved when those aren’t in use.

Yes, it was indeed a DNS issue - it appears to be linked to the way symlinks are handled in Bedrock.

This was a tricky one to figure out, so I’ll leave the solution here in case anyone has a similar problem:

One of the conventions of VVV is to use .dev as a virtual host domain name for development sites.
But lately some developers have started having problems accessing local .dev sites, a discussed here:

and here:

and here:

It turns out the issue stems from having the /etc/hosts file symlinked while using certain versions of certain browers on OSX (for me, the problem manifested while using Chrome 40.0.2214.111 (64-bit) but not Firefox). “If /etc/hosts file is a symlink OS X does a DNS lookup first and only looks at /etc/hosts if it doesn’t resolve.” It appears ICANN is now resolving .dev and certain other domains to to alert people to name collisions.
Changing .dev to .vvv solved the problem for me, as .vvv does not resolve when OSX does a DNS lookup.
For me, the problem only mainfested in a local site built with Bedrock. I tested an identical VVV setup on a site built with vanilla Wordpress core, and it worked fine. So my guess is there is some conflict with the way Bedrock is handling symlinks?
In the long run, VVV should change its conventions to not use .dev.

Not sure if it applies, but sometimes when I first go to a .dev site, I have to add the http:// in front of it, or else I can’t get to the site. I assume since .dev isn’t an actual URL ending like .com

Assumption incorrect. .dev is an actual domain, just like .com
It is managed by Google
Every single domain[wildcard] in the .dev domain is
It’s for internal development. Figure out how to assign that address to your dev box and you can use it too!