Roots Discourse

Bedrock nginx 404 error

Hi

Getting 404 after installing Bedrock with WP Local.

Following video here: https://www.youtube.com/watch?v=wNSaP-O5wrk

and instructions here: https://roots.io/guides/local-bedrock-development-with-local-by-flywheel/

It is unclear if bedrock has changed the file name to site.conf.hbs? There is no reference to this type of file name in the documentation.

server {
	listen {{port}};
    root   /Users/{name}/Local\ Sites/{name}/app/bedrock/web/;
...
}

I also tried, as per documentation:

server {
	listen {{port}};
    root   /app/bedrock/web/;
...
}

Reset Local but still getting a 404.

.env

Again normally I do not include ’ ’ around variables but upon opening the file I was not 100% certain as to why there were. Followed the instructions here:

DB_NAME=local
DB_USER=root
DB_PASSWORD=root
WP_ENV=development
WP_HOME=http://localhost:10003
WP_SITEURL="${WP_HOME}/wp"
WP_DEBUG_LOG=/path/to/debug.log

Still getting 404.

Tested to make sure that it is not an issue with Local, I have fresh install working fine.

Not really sure what to do now, I know that it is a nginx config error, just out of ideas of where to look.

Thanks

Hi @tomphilpotts,

Have you run composer install from the ../site directory?

I sorted out the issue by doing a clean install of OSX. Not sure if it was because I was using MAMP previous and it was causing an issue. But since rebuilding with Valet, not had an issue.

Thanks

Hello, Could you explain how you fixed the problem, please? I have the same error.