Bindfs Error


I’ve been trying for several days to get trellis working and have been jumping from problem to problem. I’m on a Mac with Yosemite installed. The last error I had was the wrong version of Ansible. I’ve now got the latest version installed but now I’m encountering the following error:

==> default: Bindfs seems to not be installed on the virtual machine, installing now
The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!

apt-get install -y bindfs

Stdout from the command:

Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
Need to get 24.9 kB of archives.
After this operation, 82.9 kB of additional disk space will be used.
Err trusty/universe bindfs i386 1.12.3-1
  Could not resolve ''

Stderr from the command:

E: Failed to fetch  Could not resolve ''

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I’m now at a dead end and have no idea where to go from here. Any help would be greatly appreciated.


Seems like this may be a connection issue. Are you able to manually resolve that uri?

If you’re trying to provision a remote server and seeing this error can you login to the remote and curl/wget/ping/resolve the uri?

Yeah, it’s a networking/connectivity issue. Not much we can do since it’s not on our end.

  1. Always try from scratch again: vagrant destroy then vagrant up.
  2. Do you have any sort of firewall which would prevent this?

I’m not sure this is a connectivity issue. I’m experiencing a similar problem, but it seems to be something wrong with the multisite box specifically. My local host can resolve no problem, as can a trellis box running not-multisite. But the multisite box cannot resolve the domains, either when running the playbook or when I vagrant ssh in and try to manually ping the hosts.

To make sure this was still an active issue: I pulled down all of the most recent changes to trellis (as of Feb 16, 2017) in both the single-site and multisite boxes, reloaded, and tried again. Same result. Vagrant destroy and up does not resolve the issue. Host is MacOS Sierra, with Virtualbox 5.1.14, Vagrant 1.9.1, and Ansible

Any ideas what might block domain resolution only in the multisite box? Is that a landrush issue?

@apmarshall Try using Vagrant 1.8.6 for compatibility with landrush (notes).

If you’re using brew, you could try these commands (untested)…

# may make a cleaner uninstall of vagrant to remove plugins first
vagrant plugin list

# repeat this for your plugins
vagrant plugin uninstall <pluginname>

brew cask uninstall vagrant

# this installs 1.8.6
brew cask install

# repeat this for your plugins
vagrant plugin install <pluginname>
1 Like

@fullyint Will give this a try, thanks!

Update: Worked perfectly. Cheers!

1 Like