Roots Discourse

Bindfs hangs

#1

I am using Windows 10, and have mounted using NFS in the past. But for the life of me can’t get it to work anymore on any of my projects. I am using the most current Vagrantfile/trellis project. winnfsd and bindfs vagrant plugins are the most current as well.

What I have found was it hangs on task Change site owner to user. I looked at the task, it’s changing ownership of the site folder on the VM. From another shell, logged into the VM, and ran

ps -ef|grep bindfs

Here’s the output. It just hangs indefinitely. The folder /vagrant-nfs-mydomain.dev exists, and has the contents of my site folder, so it appears to be mounting correctly, but the bindfs process halts the local dev provisioning process.

root      6622     1  0 14:46 ?        00:00:00 bindfs --force-user=vagrant --force-group=www-data --perms=u=rwX:g=rD:o=rD -o nonempty /vagrant-nfs-mydomain.dev /srv/www/mydomain.dev/current

I’m going to let it run all day and night on this computer, and when I get back to work in the morning to see if it’s still hanging. But does anyone have any thoughts on this?

0 Likes

Vagrant up stuck at TASK [wordpress-install : Change site owner to user]
#2

vagrant up as admin?

The whole Windows + NFS + BindFS setup is pretty ugly, and adding to the fact that you’re using Windows 10 and presumably you’re on Vagrant 1.8.x, it’s not surprising at all that you’re having issues.

You could check out any of these issues to see if the suggestions in them help you: https://github.com/winnfsd/vagrant-winnfsd/issues

If you think it’s limited to that Trellis task, then simply disable the task and see how that works out.

0 Likes

#3

Yeah, I’ve always done vagrant up as an admin. What I can’t understand is what caused it to stop working for me. Was it upgrading ansible to 2.0, trellis changes, or something else. I’ve been on Win 10 for a while, since I started using trellis. Winnfsd & bindfs have never caused me issues. I was on Vagrant 1.7.3 until this morning when I tried this whole process. Decided to try upgrading everything when it started hanging during the bindfs process.

Just can’t get it to get past the bindfs process. Going to disable that one task just to see if it will complete, but I would assume setting the site owner to the web_user is important, so I’m still looking for an answer as to why the bindfs hangs when running on the guest.

0 Likes

#4

Did you find a solution?

vagrant@pat:~$ ps -ef|grep bindfs
vagrant 2785 16411 0 05:17 pts/0 00:00:00 grep --color=auto bindfs
root 2819 1 0 04:33 ? 00:00:00 bindfs --force-user=vagrant --force-group=www-data --perms=u=rwX:g=rD:o=rD -o nonempty /vagrant-nfs-pat.com /srv/www/pat.com/current

0 Likes

#5

No I haven’t figured out a long term solution. I just had to uninstall the winnfsd vagrant plugin and it provisioned correctly. You can get it to boot that way, but you won’t get the performance boosts. I am probably going to setup a dual boot now on my machine just to get past all these Windows issues.

It’s just unfortunate because I know there’s a solution since this worked flawlessly for many months on many repos. There was some update to some project dependency along the way that did this. Just not sure what.

0 Likes

#6

Uninstalling the winnfsd plugin makes it work because of the Vagrantfile logic. When that plugin isn’t present on Windows, it does the regular boot cycle, which doesn’t include the bindfs command

0 Likes

#7

thanks, im gonna try uninstalling winndfsd.

I was actually planing on installing ubuntu, cause of the windows mayhem.

0 Likes