Blade error on new bedrock/sage install

i am getting the error

Fatal error: Uncaught Error: Call to undefined function Illuminate\View\Compilers\token_get_all() in /data/web/app/themes/dbg/vendor/illuminate/view/Compilers/BladeCompiler.php:170 Stack trace: #0 /data/web/app/themes/dbg/vendor/illuminate/view/Compilers/BladeCompiler.php(120): Illuminate\View\Compilers\BladeCompiler->compileString(’@extends(‘layou…’) #1 /data/web/app/themes/dbg/vendor/illuminate/view/Engines/CompilerEngine.php(51): Illuminate\View\Compilers\BladeCompiler->compile(’/data/web/app/t…’) #2 /data/web/app/themes/dbg/vendor/illuminate/view/View.php(142): Illuminate\View\Engines\CompilerEngine->get(’/data/web/app/t…’, Array) #3 /data/web/app/themes/dbg/vendor/illuminate/view/View.php(125): Illuminate\View\View->getContents() #4 /data/web/app/themes/dbg/vendor/illuminate/view/View.php(90): Illuminate\View\View->renderContents() #5 /data/web/app/themes/dbg/vendor/roots/sage-lib/Template/Blade.php(58): Illuminate\View\View->render() #6 /data/web/app/themes/dbg/app/helpers.php(55): Roots\Sage\Template\Blade->r in /data/web/app/themes/dbg/vendor/illuminate/view/Compilers/BladeCompiler.php on line 170

it appears to be blade compiling error. The steps i followed were

composer create-project roots/sage dbg && cd dbg && yarn install && yarn start

and then served the site via

wp server --docroot=web --host=0.0.0.0"

Solved: I was building the docker image from alpine, and it requires php7-tokenizer

Thanks.

1 Like

This topic was automatically closed after 42 days. New replies are no longer allowed.