Blank page server. using bedrock

so i did this step .

Run composer create-project roots/bedrock dev-master (path being the folder to install to)
Edit .env and update environment variables:

…auth key…

but now when i open localhost/test2 i am redirected to

s what to do now ? how to add ftp and cpanel . iam confused


If Wordpress does not have the DB set up yet, then that’s the address it will redirect you to, /wp-admin/install.php.

I’m not sure what you mean by “add ftp and cpanel”, Bedrock doesn’t handle your entire server, it’s just the Wordpress installation.

but i have database in phpmyadmin so why its not working

so how i can show the website to client when i working locally. i am confused now

The install page sets up the database with the records that WordPress needs to run; a blank database is not sufficient. Either complete the install there or look into WP-CLI to do it from the command line.

How did you show clients your work previously? A staging server? Nothing should change in that respect except that you’re using Bedrock to power it.

i have empty database. but the installation doesnt work so how i can install the dataabase?

I showed the through FTP- classical way.

What error do you get on the install page?

If you need FTP access on your server, you’ll have to add it yourself (as per Kalen’s comments).

i am getting cant connect to database . password and username is correct for sure

but when i working locally i need to copy files through FTP ?

If the credentials are right, you’ll need to change the DB_HOST to match your setup. If you’re on Windows then you’ll have to search online to figure out how to do this.

For Unix-like systems you should be able to use: lsof -i4 -P | grep -i mysql in the terminal. The final column will be the IP and the port you need.

I’m guessing when you said FTP, you meant you FTP’d the site to a staging server and your clients would view the site through there. Bedrock will not change this. You could set things up locally to allow the client to connect directly to your local machine but this is almost always a bad idea.

so i have composer now, after will install capistrano and want use git and .

I working for a small company. I am the only webdesinger, but dont want to use ftp everytime i make changes locally. whats your suggestion ?

Bedrock envisioned three environments. A local server for development (i.e. your own machine), an external staging server for review/testing and an external production server for the finished app.

When developing locally, it should only be you who has access. There is no need for FTP as it’s the local files that are being served.

When you have a site ready for review, you commit and push your changes and can deploy to the staging server via Capistrano. You then do the same again for the production server, when the app is good to go. At no point is FTP required.

Do you have WordPress running locally?

yes i have wordpress locally. how to deploy with capistrano to my webserver without ftp? thanks for you help and advice

Follow the instructions in Bedrock, or consider Scott’s screencast ($12).

ok. thanks.

but why the database is giving error. i followed instructuons on bedrock

Did you try changing DB_HOST as I suggested above?

i have localhost. what you want me to change to ?

I told you how to find what to change it to earlier in the thread. As an educated guess it needs to be: localhost:8889 or localhost:3306

Advice being ignored is my cue to stop giving it. You’re on your own. Good luck.

foxaii but i still dont understand this.

This is my process:

  1. install git
    2.install composer in my folder = composer.phar
  2. install bedrock in my folder on localhost
  3. edit .env and add my database from my localhost with redirection
  4. after i try to open localhost:8888 on my mac i am redirected to http://projects.qbf.bedrock-test/wp/wp-admin/install.php

this is my .


so what to do now? copy all the files to my server and create database on my server ?

Your DB_HOST is still wrong. The answer is still in this thread.

so this is my port
mysqld 9605 alan 10u IPv4 0xxxxxxxxxxxxxxxx 0t0 TCP *:8889 (LISTEN)

i changed the DB_HOST=localhost:8889

but now hen i open my localhost:8888 i am redirected to
i tried to open localhost:8889 but it download some “download” file

When you’re running Bedrock locally, the .env settings should reference the local environment i.e. WP_HOME=localhost:8888

You then need a separate .env for each different environment, e.g. (staging) and (production).

On the staging and production servers the .env file needs to be in the shared folder so that it doesn’t get overwritten on every deploy.

Why do you want to use Bedrock? You seem to have a very confused view of what it is and what it does.