Roots Discourse

Browsersync not show changes in (only) SCSS

#1

Hallo,
I am not able solved problem with my settings.

  • When I change in SCSS (part which is imported in main.scss) browser init the change in popup message writes: rebuild and then webpack built … in …ms - but without changes in browser
  • when i change in blade template - its immediately changed in browser - its ok
  • when i change in setup.php - its immediately changed in browser - its ok
  • in case yarn build - then are changes from scss visible - its ok

I tried kill yarn, yarn, yarn start

in setup.php i have: wp_enqueue_style(‘sage/main.css’, asset_path(‘styles/main.css’), false, null);
in config.json i have:

{
“entry”: {
“main”: [
“./scripts/main.js”,
“./styles/main.scss”
],
“customizer”: [
“./scripts/customizer.js”
]
},
“publicPath”: “/wp-content/themes/ad”,
“devUrl”: “http://www.ad.test”,
“proxyUrl”: “http://localhost:3000”,
“cacheBusting”: “[name]_[hash:8]”,
“watch”: [
“app//*.php",
"config/
/.php",
"resources/views/**/
.php”
]
}

I am using new Sage, Win10 with webserver Laragon with virtual host www.ad.test…

Can you help me please?

Ivo

0 Likes

#2

Classic. Anomalie.
I create new project and set whole new project. Everything its ok! Uf.

0 Likes