Bud not recompiling after starting yarn dev (docker setup)

Hi community!

I love to work with docker so i decided to setup a wordpress/sage10 project with docker. So far so good everything is working fine. When I start yarn dev I can see my website in browser and when I do some changes in code it will reload. But here is the problem: I get bud to compile my code with yarn dev on the first run but it won’t recompile when I make changes. What I mean by that is that any change in code won’t affect. I get the same output as from the first build.

I’d be very grateful for any ideas!
Thank you in advise!

What OS (for running Docker on) are you using and where are the source files located?
It may very well be that changes to the files aren’t noticed by bud.

Hey strarsis!

Thanks for replying. I’m running docker on Windows 10. The source files are located in the default directory of the sage 10 installation → wp-content/themes//resources. I haven’t changed any default setting or default config. The only thing I tried was the settings for proxy (http://wp-sage.local) which I also set in my hosts file in Windows) and serve('http://localhost:3000). I can start the dev server with yarn dev without any errors. And it seems to recognize changes in the source files due my browser reloads every time I make a change. But as I mentioned the changes are not beeing applied in the browser.

@mcKanses: So I think the reason is that Docker mounts the file system into the container in a way that doesn’t support file system notifications. As a workaround you can enable file system polling in bud (underlying fs watcher (currently chokidar)):

If this workaround fixes your issue, it indicates that the files were placed or mounted in a non-optimal way.