Can't optimize and copy images to /dist with gulp

Hey guys,

Everything work fine so far with sage 8 but I have stumbled upon an issue with gulp : I can’t put images in my folder /images/ and then run in terminal “gulp” or “gulp watch”. Well, in fact, I tried to put two small pictures and it worked and one of them got optimized. But then, I tried to put 5 more images in the folder /images/, each of them have a size of around 200 KB and a dimension of 1400 x 700. I tried again “gulp” or even “gulp watch” and it showed me this error:

  throw er; // Unhandled 'error' event
Error: spawn EACCES
at _errnoException (util.js:1003:13)
at ChildProcess.spawn (internal/child_process.js:340:11)
at Object.exports.spawn (child_process.js:499:9) 

Not sure what is going on behind the curtain when this error shows up. Anyone know how to fix this issue?

I finally removed all of my big images and it worked. Unfortunately, I can’t see anything about limit size and using gulp, even in the textbook that I bought.

There isn’t an internal image size limit. EACCES errors usually mean a permissions issue, or an outdated (or incorrect) version of node. I ran into a similar issue several years ago, it might help you diagnose the problem: Gulp dies when images are added, or when running ‘gulp’ or ‘gulp build’ [solved]