Changes in blade templates not injecting into the page


#1

I’m trying to get started with v9 of sage. All styles and scripts are injecting properly, however the changes in blade are not injecting on the page.

I have seen the recent (now fixed ?) issues with this, but I am on the latest version.

Im currently working in WSL on windows, but have the same issues when just using node on windows.

Any ideas ?


#2

When you say you’re using the latest version, do you mean you cloned the master branch?

I would recommend cloning (or downloading) the master branch if you haven’t done so already.


#3

Used composer “dev-master” . Last commit was

commit 1f062301183118d19408ad1a6546c142c288e3d6
Author: QWp6t
Date: Sat Apr 15 16:11:34 2017 -0700
Update dependencies

Just wiped and tried with a git clone instead and I get the same issue. Also it does not make any difference if I disable the HTML Injector plugin in the browsersync UI


#4

This is happening to me also, but I’m on Windows 10.

It should be noted that I did NOT have this issue with the last site I built with Sage 9, beta.2 as it was on March 9th when I used Composer to create the project and Yarn to install dependencies.

However on April 20 I set up another project and installed the latest dev-master and changes to Blade templates were no longer being injected.

I just re-installed the entire project, since I saw there’s a beta3 that came out the next day. I thought maybe that fixed the issue but apparently not.

The watch task appears to work otherwise. The styles and images all get injected. But when I make changes to blade templates, I have to hit refresh on the browser to see them.

If there’s any other info I can provide to help, do let me know. I’ve gotten quite spoiled about having to hit refresh while developing. :smile:


#5

@maguijo looks like we are the only ones. I am on windows 10 also.

I managed to get it working by changing the watch path glob to /**/*.php ( i think, not on my machine at the moment ) so can only assume that there is an issue with the way node is interpreting the paths on windows . Hope that helps !


#6

Thank you for the reply. The watch task is this:
“watch”: [
"{app,resources/views}/**/*.php"
],

When you get back to your computer, could you check what you changed it to that works?
Thanks!


#7

I changed the glob in the watch task to this, and it works now.
“watch”: [
"/**/.php"
],


#8

Also working on Windows 10 and having same problem with php files. Seems like “{app,resources/views}//*.php" cant catch files at all, can’t find solution. The "//.php” doesn’t work. Also tried “…/views/**.php” and much more - nothing. Quite strange.