Roots Discourse

Class 'App' not found

Been searching for answer here on how to fix this error but to no avail and running composer create-project roots/sage your-theme-name in my local has never been a problem to me until that error shows up on my local development upon installation. Can someone help me here?

It seems the error only occurs in php version 7.3.6 and decided to revert back to 7.3.4 php version

I’m also having this problem using PHP 7.3.7.

I have been using Roots Sage fine in a local VVV set up. I recently upgraded to VVV 3.0 which upgraded the PHP version to 7.3.7. This broke all of my local installs using the Roots Sage theme. I have tried a clean Roots Sage install and still get:

Uncaught Symfony\Component\Debug\Exception\FatalThrowableError: Class ‘App’ not found on page load.

A colleague of mine is using the same set up with PHP 7.3.2 and Roots Sage is working fine.

Is there a fix without rolling back the PHP version as I’m not sure how to rollback the PHP version in VVV?

Same problem. PHP 7.3.7 using trellis.

Its my first time trying the roots package, and after some problems trying to set up trellis in a local windows machine, I finally made it work. But I’m having this problem when installing the sage theme following the docs instructions.

I dont know how to rollback to a previous PHP version. I tried
sudo service php7.1-fpm stop sudo service php7.2-fpm start
but then the site throws 502 Bad Gateway.

This topic was automatically closed after 42 days. New replies are no longer allowed.