Couldn't get my styles to inject with gulp/ browser sync

I have a bedrock site up , but it was strange because before I ran gulp, the homepage was styled. I thought I had to run gulp to get the styles injected into the homepage. But my problem is that when I run gulp watch, and try to mess with _global.scss and create some styles to see if browser sync is working nothing happens.
My terminal tells me wiredep runs… And finishes… And then 2 files change (main.css, editor-style.css) and then it’s finished, but the changes never happen. I tried delete node_modules and run npm install again along with Gulp to compile and the problem continues.
i went and updated my npm and then ran " npm cache clear && rm -rf node_modules && npm install " ran gulp and then gulp watch I changed the body style to see if the styles would be injected. i got in the terminal
[BS] Access URLs:

Local: http://localhost:3000
UI: http://localhost:3001
UI External:

[BS] Watching files…
[14:45:16] Starting ‘wiredep’…
[14:45:23] Finished ‘wiredep’ after 7.05 s
[14:45:23] Starting ‘styles’…
[BS] 2 files changed (main.css, editor-style.css)
[14:45:30] Finished ‘styles’ after 6.56 s

but no changes happened in my browser. I’m trying figure out where I went wrong? I don’t get any errors when installing npm or running gulp.

node -v && npm -v && gulp -v
[15:00:28] CLI version 3.8.11
[15:00:28] Local version 3.9.0

i must apologize for this question, I resolved the issue and it had nothing to do with a problem occurring in the sage theme or gulp file what so ever, it was my bad, so sorry for the waste of time anyone spent looking at this.

Internet police here :rotating_light: :rotating_light: :rotating_light: — please don’t say you’ve resolved your issue without providing information on how you solved it.

Just a general FYI on this topic - I just spent some time troubleshooting an issue with Sage and Vagrant (NOT Bedrock) where browser-sync appeared to be working but was not showing the correct injected CSS.

The answer was that Nginx on my Vagrant setup had the ‘sendfile’ setting set to ‘on’, setting it to ‘off’ in my nginx.conf immediately fixed the problem.

Hope this helps someone.

1 Like

Oh, sorry Ben, I had the default theme activated for the WP install and not the sage theme. I was so embarrassed that I intentionally decided it wasn’t worth mentioning to hide my stupidity. For some reason I didn’t think there were any other themes installed so I never even looked at what theme was active.