Deploy Fails after Provisioning using latest Trellis

Upgraded to the latest Trellis, provisioned just fine. I can ssh without using my password in the DreamCompute box with the admin user I added to the users.yaml too. But then when I try to deploy I get:

SSH Error: data could not be sent to the remote host. Make sure this host can
be reached over ssh
fatal: [site.nl]: UNREACHABLE! => {"changed": false, "unreachable": true}

When I ssh into the box it is a bit slow at the moment. Could that be the issue? Or is it perhaps something else?

Looks a lot like “Example 1” output in docs for troubleshooting host key change

That worked. You are appreciated a lot! Did get into

php7.1-fpm.service is not active, cannot reload.
fatal: [imagewize.nl]: FAILED! => {"changed": true, "cmd": "sudo service php7.1-fpm reload", "delta": "0:00:00.033723", "end": "2017-03-08 11:50:46.206379", "failed": true, "rc": 1, "start": "2017-03-08 11:50:46.172656", "stderr": "php7.1-fpm.service is not active, cannot reload.", "stdout": "", "stdout_lines": [], "warnings": []}

Then a sudo reboot did the trick. After that when checking the process I saw:

systemctl status php7.1-fpm -l
● php7.1-fpm.service - The PHP 7.1 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php7.1-fpm.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2017-03-08 12:26:08 UTC; 13s ago
     Docs: man:php-fpm7.1(8)
 Main PID: 838 (php-fpm7.1)
   Status: "Processes active: 0, idle: 1, Requests: 1, slow: 0, Traffic: 0.1req/sec"
   CGroup: /system.slice/php7.1-fpm.service
           ├─838 php-fpm: master process (/etc/php/7.1/fpm/php-fpm.conf)                      
           └─935 php-fpm: pool wordpress

Thanks again for your help @fullyint !

2 Likes