Roots Discourse

Deploy hangs during task [Get WP theme and stylesheet roots]

Today I suddenly experienced issues with deploying my multisite to my staging environment. Everything has been running fine for the last month, but I tried to deploy today and ran into an issue (don’t remember exact what issue) with deployment. When I tried to debug it, I found out I didn’t have any space left on my DO droplet. Normally my site takes up something like 6.4GB, so something used up the remaining 25GB.

I rebooted the droplet and the capacity of the HD returned back to normal, but without me doing anything, I noticed the HD slowly filling back up. I tried to re-provision, but got some errors (don’t remember what errors).

The next thing I tried was a deploy rollback. That seemed to work. From that moment on, my HD wasn’t filling back up again.

After that I was able to re-provision. I removed my last commit, so my code is the same as the working code deployed to production. But when I try to deploy again, it takes an eternity on the task [deploy : Get WP theme template and stylesheet roots] and when it finally continues and goes to the task [deploy: Remove WordPress transient containing old release path], I get the following error (replaced my IP address):

System info:
  Ansible 2.7.13; Linux
  Trellis 1.2.0: October 11th, 2019
---------------------------------------------------
The conditional check 'site_transient_theme_roots.stdout != ''' failed. The
error was: error while evaluating conditional
(site_transient_theme_roots.stdout != ''): 'dict object' has no attribute
'stdout'
fatal: [this.is.my.ip]: FAILED! => {}
        to retry, use: --limit @/var/www/nexus_institute/trellis/deploy.retry

While it ran, the space on my HD was filling up again. When I check top on my droplet, I see 4 or 5 PHP processes taking up a lot of CPU (together probably almost 100%). I have no idea what’s going on. Any ideas?

That error usualy happens when using the wrong python version.

The php usage problems sound troublesome. Are you sure all the plugins are ok? Maybe check vulnwpdb?

Not much later after I posted the site went down. I think there was something seriously wrong with my install, so I just rebuild, reprovisioned and redeployed. Still have no idea what happened, but everything seems to be working for now.