Deployed website not visible


For the last weekends I’ve been playing around with Bedrock and Trellis. Started with this guide:, worked through some issues and was finally able to deploy my WP staging environment to Digital Ocean.

I’m running Ansible 1.9.4 and set up the domain name with Digital Ocean correctly (checked with them, since I thought that could be the issue). Both provisioning as deploying worked out without any error.

However if I open the url (, the browsers returns an error.
Edit: the returned error is a “can’t connect to the server” error.

Beneath is an image of my folder structure. There’s a mysterious ‘DEPLOY_UNFINISHED’ file, with no content in it.

What could be wrong / what are some steps I can take to further debug the deployment?

There were no warnings/errors during the deploy? A log of the output will be helpful to debug it.

Error log on the server is empty. I rebuilt my Digital Ocean droplet and did provision + deploy again. Still no errors, but the same issue. Here’s a copy of my command line:

Two things to notice:

  1. Provisioning is on changed instead of ok, because I forgot to run provision with the -K (sudo) parameter. Which is necessary in my setup to get apt-get installed.
  2. Beneath is my folder structure, optimised to run multiple projects (in the future) from one trellis setup/vm


I don’t think I’ve ever had to do this. Which Digital Ocean image are you selecting when you create a new droplet?

Ubuntu 14.04.3 x64
20GB SSD Disk
512MB Ram
Amsterdam 2

I’m not sure adding -K for become (sudo) was actually achieving anything because server.yml already runs with become: yes. You may find that you can omit -K in the future. The apt-get connectivity issue may have been just a temporary unavailability, as sometimes happens, and not a sudo issue.

Edit. If you set sshd_permit_root_login: false you’ll need to use -K to be prompted for the become password for the admin_user.

What’s the error?

:arrow_up: If this is your repo structure, then you should have repo_subtree_path: (Your CLI output showed repo_subtree_path: site)

If your repo is only, without the trellis directory, you should comment out repo_subtree_path.

This thread mentions the same tutorial you mentioned. Perhaps you’ll see some similarities in troubleshooting the resulting setup.

“Can’t connect to the server”

You’re absolutely right, had a dirty repo with both a ‘site’ and a ‘trellis’ folder, however since that trellis was no longer in use it was redundant. Cleaned up git, put bedrock files in root and commented the repo_subtree_path line.

However, the issue stays the same. No errors, but still a “can’t connect to the server” message.[quote=“fullyint, post:6, topic:5768”]
This thread mentions the same tutorial you mentioned. Perhaps you’ll see some similarities in troubleshooting the resulting setup.

Stumbled upon this thread too, was really happy when I started reading, because the problem seems to be similar. However, it seems to be an issue with an outdated Trellis version. I’m on the latest version (did a new clone yesterday).

@fullyint @swalkinshaw Are there further steps I can take to debug this and get it working?

After further scrutinizing your CLI output a bit, I see this:


Notice that the defaults include the http:// protocol, so try this instead:


Then (maybe destroy/rebuild droplet and) rerun server.yml and deploy.yml.

If the site still doesn’t load after that, you may want to compare your various customizations with the Trellis defaults, trying to catch customizations that might be problematic (like dropping the http:// protocol above).

If that still doesn’t work, my honest best recommendation is something I’ll quote from another thread: "…with all that you’ve learned…

1 Like