Deploying to a host that doesn't support trellis

I need to deploy my site to a staging server on bluehost. I’m pretty certain that I wouldn’t be able to install VirtualBox and the other requirements to use Trellis on this machine so I’m opting to deploy the site the old fashioned way.

I exported my database and imported it into my host.

Now I’m copying the files that were in the /web sub-directory of my bedrock site. Assuming I change wp-config.php to reflect the database credentials on bluehost~ and I manually change the site name via a Serch & Replace: should that be enough to make the site live on my new host?

There’s a lot going on under the hood that I don’t understand with Trellis and Bedrock so I guess I’m asking here to see if I’m missing something obvious.


That’s basically it… you will want to make sure you set the WP_HOME constant to where you have WP installed, and probably also set WP_ENV to staging. Other than that, the wp-config.php file should look pretty standard…

Anything that doesn’t work if either of us forgot, I’m sure you can fix by looking at Bedrock’s config/application.php file

Still no luck- the first issue was that it seems like not just the web directory is necessary, but the directory above it… considering the first call in web/wp-config.php is to a file in vendor.

I uploaded everything from the directory above web now so that the root directory of my site contains:
config/ vendor/ web/ CHANGELOG CONTRIBUTING ...

Then I read somewhere that it’s necessary to run composer install on deploys- so I installed composer and ran composer install (although it was hard to tell if it really worked).

I manually edited the wp-config-sample.php to reflect the database credentials and then ran a Search & Replace on the database.

Now the only thing that’s odd is that all my plug-ins are missing. What could be the cause? I know the folder structure is different for bedrock but I don’t see why the plug-ins aren’t being picked up in the app folder.

Thank you for any help.

manually copying plug-ins and uploads folders from the app directory to the wp-content directory… :confounded: