Roots Discourse

Deploying Trellis to Binary Lane

Having a problem deploying to Binary Lane, an Australian alternative to Digital Ocean. I was able to get this same site deployed to DO, but having no luck with BL.

When running ./deploy.sh production example.com I get an error:

fatal: [103.16.128.102]: UNREACHABLE! => {"changed": false, "unreachable": true}

Having read through some other threads on here with similar issues I’ve tried the following:

ssh -o PasswordAuthentication=no root@103.16.128.102 "echo can_connect" ||

And I get the echo can connect.

I’ve also tried:

ansible 103.16.128.102 -m ping -i hosts/production -u root -vvvv

And I get Success

Is there something else I can try to debug this connection? Thank you.

I’ll answer my own question here to an extent … I had to re-build the production server but including the following to ansible/roles/common/tasks/main.yml

Under with_items:

  • systemd-services to fix a timezone error
  • util-linux to fix a fallocate error

I’m still yet to get this deployment going due to some other issue but thought I’d add these fixes here.

1 Like

We use BinaryLane also. I’m assuming you got things up and running, but here are a couple of things we need to do in our Trellis setup

Change the swapfile role:

- { role: swapfile, swapfile_size: 1000, swapfile_use_dd: True, tags: [swapfile] }

Default timezone works in this format:

default_timezone: Etc/GMT+10

You also need to disable port blocking as 22 is blocked on outgoing by default so deploys dont’ work.

We add firewall rules for Port 25 and 3389 separately.

1 Like

Yeah I did the port changes, but didn’t need to change anything with the swapfile role. I made a list of the required changes in a blog post.

1 Like

A PR to ensure those 2 packages are installed would be welcome. Do you want to care of that?