Deployment and transferring via FTP

Hi Guys,

Like many others, I seem to be having my own issues making my theme work on a live site.
I ran yarn run build:production and transferred over the App, config, dist, vendor and resources folders via FTP. After I do this I get the following error throughout the admin before I can even activate the theme (trying to activate the theme shows the same error)

I have seen this error reported in other posts but I couldn’t see a clear way to fix this…

Would love some help as I have to put this site live soon :S .

Thanks :slight_smile:

The error is pretty clear, it can’t find the file in your theme resources/functions.php, did you confirm that file is there?

Yeah it’s definitely there… really odd

the URL in your screenshot is the Permalink settings page in wp-admin. Does this error appear on all pages of the site? Including the bare domain?

EDIT: I guess I can check that myself. Yes it does.

That file may be present in your theme, but also check to make sure that your theme is where your server expects it to be. You can see the location it’s looking for in the error message.

Hey it’s fixed! What did you do?

haha I have no idea, I just did another build:production and uploaded EVERYTHING, even node_modules folder, even though I know I shouldn’t need to, and it works now, so weird.

Sorry to waste your time guys :frowning: thanks for the fast responses, sorry again :S

You could try deleting node_modules and see if it still works?

Works without node_modules folder… there has to be one of the files in the root dir that I must of missed that’s needed…