Roots Discourse

Deployment issue - OSX to Linux?

Hey,

i’m dealing with deployment issue for a whole day, where i’m getting

Fatal error: Uncaught ReflectionException: Class Illuminate\Filesystem\Filesystem does not exist in /public_html/wp-content/themes/sage-test-theme/vendor/illuminate/container/Container.php:767 .. etc.

Localhost if working just fine but the production doesn’t.

Locally i’m using Mac with MAMP
Server is on PHP 7.2, Linux system.
Deploying with FTP manually.

The site was doing fine before i made an update. After update i’m getting error above, so i was just thinking that it could be something wrong with my theme after update… So i also decided to go from 0, create project and follow the guide but still the same issue, without changing anything.

I have tried update composer, chmod 755 on wp-content (all the possibilites i found)

Using other theme like Twenty Twenty seems to work, so that’s why i’m guessing it’s problem somewhere with the theme.

Thanks for any idea or help.

Problem solved, after trying many installs and after changing hosting, i wrote to support of hosting provider and the issue was that they were automatically deleting one /vendor/illuminate/filesystem/Filesystem.php file.

Working fine now :slight_smile:

This topic was automatically closed after 42 days. New replies are no longer allowed.