Disabling E_NOTICE in php 7..1 on development environment

I’m trying to remove php Notice from error reporting on dev environment. I’ve put “E_ALL & ~E_NOTICE” in php_error_reporting variable in group_vars > development > php.yaml, but nothing happens (still reporting Notices).
What am I doing wrong?



Did you re-run vagrant provision?

Yes, and I see the correct values in /etc/php/7.1/fpm/php.ini. But it’s still reporting (f.e: "PHP message: PHP Notice: A non well formed numeric value encountered in…)

Maybe you have to update WP_DEBUG as well: https://github.com/roots/bedrock/blob/master/config/environments/development.php#L4

1 Like

I’ve disable WP_DEBUG and now it works as expecred.

Thank you!