Roots Discourse

Error on 'vagrant up': The following settings shouldn't exist: ruby

trellis

#1

Hi guys!

I’m trying to run ‘vagrant up’ to create a new development environment.

This results in the following error message:

`The following settings shouldn't exist: ruby`

I have no clue why this message is occurring. Using:

  • Trellis 1.0.0
  • High Sierra (10.13.6)
  • Ansible 2.5.3
  • Vagrant 2.1.1

Any help would be highly appreciated!

Edit: I am able to vagrant up existing environments, with Trellis version up to pull 1021.


#2

We had the same issue, upgrading Vagrant to 2.2 solve the problem.


#3

Thanks Zessx! That was it. I’m thinking the new update for Trellis might require version 2.2.