Roots Discourse

ERROR! Trellis no longer supports Ansible 2.4.0.0

I just had this error when installing trellis.

ERROR! Trellis no longer supports Ansible 2.4.0.0.
Please upgrade to Ansible 2.5.0.0 or higher.

As per an older post, the solution is to run the following command on your host machine:

pip install ansible==2.5.0.0

Hope this helps someone! ( Thanks @swalkinshaw )

1 Like

Just a note in case anyone else has this problem:
We ran sudo pip install ansible==2.5.0.0 and tried to boot our vagrant box, but we kept running into this error:
Trellis no longer supports Ansible 2.5.0. Please upgrade to Ansible 2.5.0.0 or higher.
Trellis was confused because our installed version was 2.5.0 while the REQUIRED version was 2.5.0.0, with 2 zeroes. To fix this I just edited the required version in trellis/lib/trellis/plugins/vars/version.py from 2.5.0.0 to 2.5.0, and the boot was successful.

I meant to post this earlier - I had the exact same problem after using sudo on the pip install command, although what fixed it for me was upgrading to ansible 2.5.1 instead :+1:

2 Likes

This topic was automatically closed after 42 days. New replies are no longer allowed.