Error with deploys from VM

I run my ansible on VM, my host machine is running Windows.
When i try to do “ansible-playbook -i hosts/staging site.yml
I get this error:
"ERROR: The file hosts/staging is marked as executable, but failed to execute correctly. If this is not supposed to be an executable script, correct this with chmod -x hosts/staging"
I think this is some problems with “x” flag, but i cant change it from VM.
Any suggestion what to do? :smiley:

I’m running bedrock on VM with ansible, my host os is Windows.

Looks like I’m alone with that problem…

This can be solved by move hosts/staging to local VM folder
But after that u need to install SSH keys (and i don’t find any reference here or on github)
U can avoid use ssh keys by adding -k modifier into ansible command - ansible-playbook -i /tmp/staging site.yml -k
With that you will be asked for root password
And finally I with another bunch of errors… maybe someone have answer …

<> EXEC ['sshpass', '-d7', 'ssh', '-C', '-tt', '-vvv', '-o', 'ControlMaster=auto', '-o', 'ControlPersist=60s', '-o', 'ControlPath=/home/vagrant/.ansible/cp/ansible-ssh-%h-%p-%r', '-o', 'Port=28106', '-o', 'GSSAPIAuthentication=no', '-o', 'PubkeyAuthentication=no', '-o', 'User=root', '-o', 'ConnectTimeout=10', '', "/bin/sh -c 'mkdir -p $HOME/.ansible/tmp/ansible-tmp-1424817442.68-103522666450270 && echo $HOME/.ansible/tmp/ansible-tmp-1424817442.68-103522666450270'"]
fatal: [staging] => SSH encountered an unknown error. The output was:
OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014
debug1: Reading configuration data /home/vagrant/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: auto-mux: Trying existing master
debug1: Control socket "/home/vagrant/.ansible/cp/ansible-ssh-" does not exist
debug2: ssh_connect: needpriv 0
debug1: Connecting to [] port 28106.
debug2: fd 3 setting O_NONBLOCK
debug1: connect to address port 28106: Connection timed out
ssh: connect to host port 28106: Connection timed out

TASK: [common | Update Apt] ***************************************************
FATAL: no hosts matched or all hosts have already failed -- aborting

PLAY RECAP ********************************************************************
           to retry, use: --limit @/home/vagrant/site.retry