Roots Discourse

Failing to install Sage theme due to an error saying 'illuminati'

I installed my WP website with Local by Flywheel and then tried to install sage through composer. But this error appears:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for illuminate/config v5.6.39 -> satisfiable by illuminate/config[v5.6.39].
    - illuminate/config v5.6.39 requires php ^7.1.3 -> your PHP version (8.0.7) does not satisfy that requirement. 
  Problem 2
    - Installation request for illuminate/container v5.6.39 -> satisfiable by illuminate/container[v5.6.39].       
    - illuminate/container v5.6.39 requires php ^7.1.3 -> your PHP version (8.0.7) does not satisfy that requirement.
  Problem 3
    - Installation request for illuminate/contracts v5.6.39 -> satisfiable by illuminate/contracts[v5.6.39].       
    - illuminate/contracts v5.6.39 requires php ^7.1.3 -> your PHP version (8.0.7) does not satisfy that requirement.
  Problem 4
    - Installation request for illuminate/events v5.6.39 -> satisfiable by illuminate/events[v5.6.39].
    - illuminate/events v5.6.39 requires php ^7.1.3 -> your PHP version (8.0.7) does not satisfy that requirement. 
  Problem 5
    - Installation request for illuminate/filesystem v5.6.39 -> satisfiable by illuminate/filesystem[v5.6.39].     
    - illuminate/filesystem v5.6.39 requires php ^7.1.3 -> your PHP version (8.0.7) does not satisfy that requirement.
  Problem 6
    - Installation request for illuminate/support v5.6.39 -> satisfiable by illuminate/support[v5.6.39].
    - illuminate/support v5.6.39 requires php ^7.1.3 -> your PHP version (8.0.7) does not satisfy that requirement.  Problem 7
    - Installation request for illuminate/view v5.6.39 -> satisfiable by illuminate/view[v5.6.39].
    - illuminate/view v5.6.39 requires php ^7.1.3 -> your PHP version (8.0.7) does not satisfy that requirement.   
  Problem 8
    - Installation request for illuminate/console v5.6.39 -> satisfiable by illuminate/console[v5.6.39].
    - illuminate/console v5.6.39 requires php ^7.1.3 -> your PHP version (8.0.7) does not satisfy that requirement.  Problem 9
    - Installation request for paragonie/random_compat v9.99.99 -> satisfiable by paragonie/random_compat[v9.99.99].
    - paragonie/random_compat v9.99.99 requires php ^7 -> your PHP version (8.0.7) does not satisfy that requirement.
  Problem 10
    - illuminate/config v5.6.39 requires php ^7.1.3 -> your PHP version (8.0.7) does not satisfy that requirement. 
    - roots/sage-lib 9.0.9 requires illuminate/config ~5.6 -> satisfiable by illuminate/config[v5.6.39].
    - Installation request for roots/sage-lib 9.0.9 -> satisfiable by roots/sage-lib[9.0.9].

I tried to update the composer but it was the latest update.
I tried to ignore platform requirements but it does not work, as yarn start will not work later.
I tried to downgrade PHP version to make it compatible but it did not work.
Anyone with a similar problem? I appreciate your help.

The output clearly states that you have PHP 8.0.7 installed, and you need a version below PHP 8.x, so 7.x. If you have the correct version installed in Local by Flywheel, you are probably running the command from your host machine. In this case, try running the command over ssh instead (right click on your website in Local > launch ssh shell).

3 Likes

Thanks, that was the solution. :grinning:

This topic was automatically closed after 42 days. New replies are no longer allowed.