First provision, data could not be sent to remote host


I’m tryning to provision my production server using this command :
ansible-playbook server.yml -e env=production

But I have this error :

SSH Error: data could not be sent to remote host "x.x.x.x". Make sure this host can be reached over ssh fatal: [x.x.x.x]: UNREACHABLE! => { "changed": false, "unreachable": true }

PS : I’m able to SSH my remote server successfully using root user from my vagrant machine, I’ve already installed a production website successfully before, but I don’t know why I can’t with this one, my server is hosted in Vultr on Ubuntu 18.10 x64

PS: My ansible version is 2.7.5
PS: -vvvv flag don’t show something relevant
PS: I’ve tried to remove known_hosts entry, same error
PS: I’ve tries dynamic_host_key_algorithms: false, same error
PS: I’ve tries to install python 2.7 on remote server, same error

Does anyone have an idea of where it comes from ?

Thanks in advance

Thanks for the troubleshooting! Is this your first provision on that server? I know you said you’ve done another website before, but not sure if its the first time for this one.

Can you post the SSH connection part of the log output using -vvvv?

You could try the ansible command as a test. Something like this:

ansible all -m ping -i hosts/production (from your trellis dir)

Also try ansible all -m ping -i hosts/production -u admin

1 Like

This topic was automatically closed after 42 days. New replies are no longer allowed.