Gathering facts after vagrant box update

I have/had nice setup between DO droplet and Vagrant box on Windows host. I had to make a copy of ansible folder in the dev box, otherwise I got some errors, but deployment to staging ran fine until yesterday. Yesterday I did a vagrant box update. Now it seems when I run ./ staging fapps, it just sits there Gathering Facts.
How can I make it more verbose?

I was assuming you wanted more output from Vagrant but I’m a little confused by your setup so if that’s wrong then let me know.

If you need more output from ./ you’ll need to edit it manually for the time being. Or just run the ansible-playbook command like this:

ansible-playbook -i hosts/staging deploy.yml --extra-vars="site=<site name> -vvvv

@Ivan_Svaljek I wonder if the “Gathering Facts” step could be hanging while silently waiting for a password as fallback authentication because the ssh key didn’t work or wasn’t available.

If deployment to staging was working from the old vagrant vm, it seems you had somehow enabled the old vm 's ssh connection to the remote, maybe by adding a private key to the vm or setting up ssh agent forwarding. I’m not on Windows but I’m interested to hear how you set that up. Perhaps you need to repeat that setup process with your new vagrant box.

1 Like

I tried once more today (a little less tired) and it seems to work. It could be the ssh, I have both pub and private keys in the same folder, so maybe I was pushing the tab key with ssh-add too much yesterday. I should setup a more permanent method of ssh authentication.

Sorry, and thanks to all.