Get Vagrant + Browsersync to play nicely with Sage

I have looked over a few articles, however, my topic hasn’t been answered completely. Many thanks in advance on what needs to be done, but I just can’t seem to figure out how to make this work…

I have mysite.local as my local site working perfectly, just installed Sage, and Browsersync (“https://localhost/:3000”) just comes back with " This site can’t be reached. Refused to connect".

Must I add something to my vagrant file to make this work together? Is my local development setup messed up? Do I need to somehow point localhost to the virtual server I just provisioned within Trellis?

Sorry for the basics, but I’m sure this will help a few others. Happy New Years! :slight_smile:

Can you please share your resources/assets/config.json file so we can see what your settings are?

Browsersync just proxies your local development site, so you need to make sure that devUrl is set to a working dev site, so mysite.local in your case (with http or https like in the config)

Hi Ben,

You’re an inspiration, thank you for the help. Here is my code for config.json.

  "entry": {
    "main": [
    "customizer": [
  "publicPath": "/app/themes/sage",
  "devUrl": "http://boothwise.local",
  "proxyUrl": "http://boothwise.local:3000",
  "cacheBusting": "[name]_[hash:8]",
  "watch": [

Nothing special in particular… Must I reconfigure my local development somehow? Just odd how it doesn’t recognize “http://boothwise.local:3000”, when “http://boothwise.local” works just fine via VirtualBox.

Thanks again!

From your initial post, it looks like browsersync is trying to proxy the https version of your site. Do you have an SSL certificate for your local dev environment? If not, do you have the “s” anywhere in your configuration that might be telling browsersync to proxy that variation of the URL?

You’re gonna want to leave this as, then everything should work

This topic was automatically closed after 42 days. New replies are no longer allowed.