Gulp watch after adding dependencies


Just added fontawesome using bower install --save fontawesome then ran gulp to compile which worked great and icons show up in my theme.

Started editing my theme with gulp watch running and suddenly fontawesome disappears. If I run gulp manually it comes back - whats going on?

This may well be related to another post

1 Like

Did you run gulp watch before or after installing font awesome and running gulp?

Hi Kalen

I stopped and started gulp watch which fixed the problem. I didnt realise that the process held its list in memory and needs a restart whenever new assets are loaded.

Thanks for the quick response!

I tried to fix that here:

But maybe it’s still not working as expected.

Just checked the code and your fix is applied, but I guess its not working… My dev system is Win7 64 WAMP if that makes any difference.

I’ll keep an eye on it while I work on my theme.

I wanted to add swipe support to my carousel so I did
$ bower install --save bootstrap-carousel-swipe
$ gulp
That seemed to work…for a while. Then I noticed it was no longer being included. Its still in bower.json. What might cause it to not be included? Is it possible that gulp watch is the culprit? Do I need to restart gulp watch after adding the package? (I had just left it running in another terminal window)

(I read the NPM debugging guidlines and node, gulp and bower are up-to-date)


What’s solved it for me is to not run gulp watch simultaneously as gulp. I used to have gulp watch it running in the background and that would removed the dependencies via Bower or Wiredep.

Yes, I believe I’ve suggested it, but it’s a good idea to stop gulp watch if you need to run gulp, or after a Bower install, etc.