Gulp watch issue - spawn EACCES

Hi, I’m having some problems running gulp watch:

--- themes/xxxxcomau-theme ‹master* M› » gulp watch         
[10:32:48] Using gulpfile /var/www/clients/
[10:32:48] Starting 'watch'...
[10:32:48] Finished 'watch' after 131 ms
[BS] Proxying:
[BS] Access URLs:
       Local: http://localhost:3000
          UI: http://localhost:3001
 UI External:
[BS] Watching files...

        throw er; // Unhandled 'error' event
Error: spawn EACCES
    at errnoException (child_process.js:1011:11)
    at Process.ChildProcess._handle.onexit (child_process.js:802:34)

I’ve tried npm cache clean, npm install etc but nothing works unfortunately.

I have a hunch that this is because my node version is out of date - it was reporting as 0.10.x not 0.12.x so we’ll see if that fixes the issue.

That might possibly be it, but it’s actually the npm version that is more important, as it’s easy to run a very old 1.x.x version of npm.

Generally what I’ve seen with EACCES errors is either

  1. Permission issues
  2. You already have gulp watch running in another process/tab
  3. Outdated npm version

Problem resolved here: Gulp watch error on fresh VM setup - EACCES errors [solved]