Gulp watch not working correctly

Hi there,

When I run ‘gulp watch’ it opens up my site in localhost:3000 and says ‘browsersync connected’ and when I make changes in my scss file it says

[18:16:51] Finished ‘styles’ after 6.42 s
[18:19:12] Starting ‘wiredep’…
[18:19:12] Finished ‘wiredep’ after 15 ms
[18:19:12] Starting ‘styles’…
[BS] 1 file changed (main.css)

However there are no changes in my browser, even when I refresh the page myself.

Any advice on where to begin trying to solve this problem?


Does the page say in the top right that Browsersync has updated, or something along those lines?

Unfortunately not! It says ‘connected to browsersync’ when I initially run ‘gulp watch’, but after that it doesn’t do anything :open_mouth:. My sass is located in assets/styles/main.scss and then localhost:3000 is looking in /dist/styles/main-5e97552ae1.css which isn’t being updated when I save. There is however a /dist/styles/main.css which is being overwritten on save!

Furthermore my mainfest.json looks like this!

{ "dependencies": { "main.js": { "files": [ "scripts/main.js" ], "main": true }, "main.css": { "files": [ "styles/main.scss" ], "bower": [], "main": true }, "customizer.js": { "files": [ "scripts/customizer.js" ] }, "jquery.js": { "bower": ["jquery"] }, "custom.js": { "vendor": ["assets/scripts/vendor/wow.js", "assets/scripts/vendor/wow.js", "assets/scripts/vendor/jquery.easing.1.3.js", "assets/scripts/vendor/SmoothScroll.js"], "bower": [] } }, "config": { "devUrl": "http://localhost:8888" } }

You’ve ran gulp --production to version the assets, probably while you still had gulp watch running. Or something like that…

Stop gulp watch, run gulp then gulp watch again.

1 Like

Awesome that fixed it! Thanks alot for your help man, much appreciated :smiley: