High CPU usage with Gulp watch

Is it normal that the CPU usage is always (I mean always) at ~20% or more when “gulp watch” is running? I’m on a MacBookPro (SSD, ram 4GB, i7 2,2Ghz). With the previous Roots+Grunt this doesn’t happen to me.

What version of BrowserSync are you using? See https://github.com/BrowserSync/browser-sync/issues/499 - try updating to the latest and see if it helps

I have the 2.2.1 version (as the issue you linked) but is it correct forcing a different version in the package.json like:

 "browser-sync": "2.2.3",

in place of

"browser-sync": "^2.2.1",


Also, I’ve seen that is out the browser-sync v.2.5.1… what version do you use/reccomend in your projects?

Use the latest. The package.json in an unmodified version of Sage will get you the latest version if you wipe your node modules directory.

The caret, on the other hand, is more relaxed. It will update you to the most recent major version (the first number). ^1.2.3 will match any 1.x.x release including 1.3.0, but will hold off on 2.0.0.

I removed the node modules directory and fired npm install. Now when launch gulp I get

    throw err;
Error: Cannot find module 'glob-watcher'
    at Function.Module._resolveFilename (module.js:336:15)
    at Function.Module._load (module.js:278:25)
    at Module.require (module.js:365:17)
    at require (module.js:384:17)

Already tried to uninstall gulp and reinstall, both globally and locally. No luck, always the same error

You’re not going to get help here for npm issues. See Npm Debugging Guidelines (Failed npm install, bower install, or gulp build? Read this).

ok it seems to be solved (even though I get some errors). thanks