Roots Discourse

How to configure linter to ignore 3rd party packages?

eslint

#1

I’m adding Font Awesome following this post importing it into main.scss

But after this, I’m not able to build the project anymore, because the styles lint is scanning the Font Awesome code and it’s failing.

How can I configure to ignore 3rd party package?


#2

Take a look at the Stylelint docs for excluding files from being linted: https://github.com/stylelint/stylelint/blob/master/docs/user-guide/configuration.md#ignorefiles


#3

Could /* stylelint-disable */ at the beginning of the 3rd party style sheet help?
Or you could try with a “.stylelintrc.json” and ignore styles.


#4

I would follow this:


closed #5

This topic was automatically closed after 42 days. New replies are no longer allowed.