Insight-bower.yml does not exist

I’m currently in the process of installing Sage and I’m up to this step https://roots.io/sage/docs/theme-development/.

I’m up to the step ‘Run bower install’. When I run the ‘bower install’ command I get this error:

/usr/local/lib/node_modules/bower/node_modules/insight/node_modules/configstore/configstore.js:66
				throw err;
				      ^
    Error: EACCES, permission denied '/Users/studio07/.config/configstore/insight-bower.yml'
    You don't have access to this file.

at Error (native)
at Object.fs.openSync (fs.js:502:18)
at Object.fs.writeFileSync (fs.js:1103:15)
at Object.create.all.set (/usr/local/lib/node_modules/bower/node_modules/insight/node_modules/configstore/configstore.js:56:8)
at Object.Configstore (/usr/local/lib/node_modules/bower/node_modules/insight/node_modules/configstore/configstore.js:19:11)
at new Insight (/usr/local/lib/node_modules/bower/node_modules/insight/lib/insight.js:23:34)
at Object.setup (/usr/local/lib/node_modules/bower/lib/util/analytics.js:18:19)
at Object.<anonymous> (/usr/local/lib/node_modules/bower/bin/bower:73:11)
at Module._compile (module.js:460:26)
at Object.Module._extensions..js (module.js:478:10)

When I try navigating to insight-bower.yml it doesn’t exist!

Anyone have any insight to this issue?

Never seen that one before. How do you have NPM installed?

Also https://discourse.roots.io/t/npm-debugging-guidelines-failed-npm-install-bower-install-or-gulp-build-read-this

I have NPM installed at the global level, version 2.5.1. Also I ran npm cache clear && rm -rf node_modules && npm install from that link you posted and the project level NPM installation worked fine.

possibly related: https://github.com/bower/bower/issues/1223

Yup already read this, I ran the chown command and I still got the exact same error :frowning:

Right now I’m just going to uninstall everything at the node/npm level and start again :open_mouth:

definitely recommend you use nvm https://github.com/creationix/nvm

Haha yeah I had this installed as well. Will start again with this. Cheers!