Roots Discourse

Install Trellis on Windows 10

I have been stuck trying to get this to work on my Windows 10 machine. I have followed the docs to a t. I configured WSL and installed Ubuntu. On the first command to run I am getting stuck.

The following command results in the output below
sudo add-apt-repository ppa:ondrej/php

Cannot add PPA: ‘ppa:~ondrej/ubuntu/php’.
ERROR: ‘~ondrej’ user or team does not exist.

I have googled and looked through all the support docs with no luck. Has anyone else ran into this issue? I would prefer to be on a mac but my current job requires me to install this on a PC. Any help is much appreciated.

  • What Ubuntu WSL distribution is this? 20.04?
  • Are you using a HTTP proxy?

Yes its 20.04 and no I am not using a proxy. Does this need a proxy setup in order to work?

Sometimes a connection issue can cause that.

Also missing CA certificates can be the cause, see this thread:

I just tried the solutions in that article. Now I am getting the following errors.

The following additional packages will be installed:
  openssl
The following NEW packages will be installed:
  ca-certificates openssl
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 621 kB/767 kB of archives.
After this operation, 1677 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Err:1 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 openssl amd64 1.1.1f-1ubuntu2.5
  404  Not Found [IP: 91.189.88.152 80]
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/openssl_1.1.1f-1ubuntu2.5_amd64.deb  404  Not Found [IP: 91.189.88.152 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I am uninstalling and re installing now. Gonna start fresh and see if the issue continues.

I setup a brand new Ubuntu and ran through all the steps in the article linked above. I am still getting the errors posted above. Do you have any other suggestions?

Have you ran apt update first?
I also get a 404 for the file http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/openssl_1.1.1f-1ubuntu2.5_amd64.deb.

Yes I did and still get the same error.

*.8 (openssl_1.1.1f-1ubuntu2.8_amd64.deb) can be found as deb file though:
http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/openssl_1.1.1f-1ubuntu2.8_amd64.deb

2.5 (openssl_1.1.1f-1ubuntu2.5_amd64.deb), 2.6 (openssl_1.1.1f-1ubuntu2.6_amd64.deb) and 2.7 (openssl_1.1.1f-1ubuntu2.7_amd64.deb) are not available:
http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/

Yeah not sure whats going on. Works fine on my mac and windows is another issue.