Installation errors with trellis/config.rb and installing vagrant plugins

  1. I had a couple of install errors from vagrant up indicating syntax errors in “trellis/lib/trellis/config.rb”. They all came from the lines similar to def initialize(root_path:). Fixed (perhaps) by removing the colon.
    Question: should it have been :root_path?

  2. Having done that I now have this
    ` $ vagrant up
    Installing plugin vagrant-bindfs
    Bundler, the underlying system Vagrant uses to install plugins,
    reported an error. The error is shown below. These errors are usually
    caused by misconfigured plugin installations or transient network
    issues. The error from Bundler is:

Authentication is required for
Please supply credentials for this source. You can do this by running:
bundle config username:password`

The same error has been referenced several times over the years with a myriad of causes.

This is a new, clean install of trellis/bedrock/vagrant following the instructions on the trellis website.

Any ideas?

OK. Solved my own problem by using vagrant version.
The version I was getting was much older than the version I installed this morning.


I thought I’d try installing vagrant on a different disk (lots more space) than the one everything else is on, and where I am working. Then I forgot that I’d done that.

Reinstalled Vagrant 2.0.2 on the correct disk and I’m moving forward again.

1 Like