Roots Discourse

Installing ImageMagik


#1

I have a client who, when they upload photos, they photos get rotated after being uploaded. This is because they contain EXIF data.

I have tried a couple of Plugins to remove it but it seems both require ImageMagik to be installed on the server. But when I am SSH’d as web I cannot sudo because it asks for a password. I tried the passwords in Vault, those were incorrect.

What am I missing here? Thanks.


#2

SSH as admin instead. That user is used for provisioning the server while web is used for deploying (which is why deploys can’t mess up your server config). Also, (instead) you might want to add a role to Trellis to do this — incase you ever need to reprovision with the same changes.


#3

Thanks Nathan. Unfortunately I cannot SSH into the server as admin. Is this normal? I also cannot copy my SSH keys to that user when SSH’d as web because it’s not the owner - of course.


#4

You can also use the apt_packages_custom key in trellis config so the package is installed on provisioning.


#5

This is the way to go; it will ensure that it persists on your next provision.


#6

Thank you all. I will rebuild this server with that. Could anyone confirm whether or not I should be able to SSH in as admin though? I’m concerned I’ve misconfigured something that is preventing me from having sudo privileges on the server.


#7

Can you (re-)provision the server? Then ansible is able to login as admin.


#8

I decided to reset the root password via Digital Ocean, access the console through the browser terminal, copy the SSH keys to admin and logged in to the server for now and will schedule a re-provision. Thanks everyone.