Installing vagrant-bindfs fails

I’m setting up a new Macbook Air and ran into an issue installing this plugin. I’m running ruby 2.3.3 but the error is saying Ruby 2.0.0 is required.

    Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

An error occurred while installing vagrant-bindfs (0.4.12), and Bundler cannot continue.
Make sure that `gem install vagrant-bindfs -v '0.4.12'` succeeds before bundling.

Warning: this Gemfile contains multiple primary sources. Using `source` more than once without a block is a security risk, and may result in installing unexpected gems. To resolve this warning, use a block to indicate which gems should come from the secondary source. To upgrade this warning to an error, run `bundle config disable_multisource true`.Gem::InstallError: vagrant-bindfs requires Ruby version ~> 2.0.0.

Any ideas on how to resolve this?



I ran into the same issue. Vagrant runs it’s own version of Ruby, not the system version.

Seems like it’s an issue with the latest version. Try vagrant plugin install vagrant-bindfs --plugin-version 0.4.11


Thanks @kalenjohnson. I found that answer shortly after I posted. I just got tied up before I could update this thread.