Roots Discourse

Issue creating fresh Bedrock install

I have been using bedrock for several months now and have had no troubles with the install until today. When I ran composer create-project roots/bedrock project-name in my terminal, absolutely nothing happened. There’s no error…it’s just stuck (see screenshot). Does anyone have any insight as to why this could be happening? As I’ve said, I’ve never run into this before.

Thanks!

  1. Tried composer self update?
  2. Invoke composer with more verbosity (-v)…

My guess would be either network issues (i.e. it’s waiting for a response from a remote server that never comes) or potentially there is a script being executed in there that’s hidden from output but is waiting for an answer from you that obviously never comes.

AFAIK the only thing Bedrock does when installed using create-project is create a boilerplate .env for you so you might try doing:

mkdir marcy-2020
cd marcy-2020
git clone git@github.com:roots/bedrock.git .
rm -rf .git
cp .env.example .env

That replicates what create-project does, and should either get you up and running or allow you figure out where the problem might be.