Roots Discourse

Keep getting: "Error: Site [mydomain.nl] not found" when deploying wp multisite


#1

I have tried starting all over again on two seperate VPSs (one with CentOS and Capistrano and now with Ubuntu 14.04 with Trellis) but I keep getting the WP-CLI error

Error: Site [mydomain.nl] not found

where [mydomain.nl] stands for my actual domain name.

I don’t know where to look anymore. I started a new vagrant all over again, but still the same error. Deployment of the code through Git works like a charm, I get the error on

TASK [deploy : Update WP theme paths]"

Additional info: I’m trying to install a multisite

Anybody any ideas? Or do I need to provide more information?

Edit, complete error:

Error: Site mountsix.nl/ not found.
fatal: [mountsix.nl]: FAILED! => {"changed": true, "cmd": ["wp", "eval", "wp_clean_themes_cache(); 
switch_theme(get_stylesheet());"], "delta": "0:00:00.081117", "end": "2016-06-16 15:52:44.707178",
"failed": true, "rc": 1, "start": "2016-06-16 15:52:44.626061", "stderr": "Error: Site mountsix.nl/ not found.",
"stdout": "", "stdout_lines": [], "warnings": []}

#2

This issue is solved. I didn’t notice the same wp-cli.yml file to be deployed to the live environment as well. I had the url variable hard set in that file. Removing the hard coded part and running a random wp-cli command with the the --url flag separate on each environment to set it globally for the corresponding domain names resolved this issue.