Roots Discourse

Local Development Setup - Vagrant Up says there is no Vagrantfile when there is

#1

I’ve been searching all over the net and this site for a solution to this issue. I’ve followed the Roots Docs and Github Docs exactly and whenever I do “vagrant up” inside the trellis directory of the roots-example-project it tells me to either do vagrant init or try changing to a directory that has a Vagrantfile in it. There is a file in the trellis directory called this and it does indeed contain all the configuration in it.

I thought it may be a permissions issue, so I tried running it with sudo, but that comes back as there is no vagrant command found.

This is what gets spat out at me when doing “vagrant up” for the initial test the installation according to the Github Docs.

bryce@DESKTOP-I7CC535:~/sites/roots-example-project.com/trellis$ vagrant up
A Vagrant environment or target machine is required to run this
command. Run vagrant init to create a new Vagrant environment. Or,
get an ID of a target machine from vagrant global-status to run
this command on. A final option is to change to a directory with a
Vagrantfile and to try again.

At this point, I’m almost ready to just install linux on my other drive and give up using this WSL shit and see if that makes a difference.

0 Likes

#2

So I get a bit further in Linux. It at least lets me do Vagrant Up for the Roots example project. But it fails at NFS mounting.

Back in Windows where I would prefer to get this working it still insists there is no vagrant environment whenever doing “vagrant up” for the first time in the trellis directory.

0 Likes